Some users experiencing issues accessing our website

Incident Report for actblue

Resolved

The issue has been identified and successfully resolved. Systems are back to normal.
Posted Apr 25, 2025 - 13:01 EDT

Investigating

We're aware that some users are currently experiencing issues accessing our website. Our team is actively investigating and working to resolve the problem as quickly as possible. Thank you for your patience.
Posted Apr 25, 2025 - 12:52 EDT