Degraded Performance in CSV Report Generation

Incident Report for actblue

Resolved

This incident has been resolved
Posted Apr 24, 2025 - 20:02 EDT

Identified

We've identified the root cause of the issue and implemented mitigation measures. We're actively working through the backlog of CSV reports and will continue processing them until fully resolved.
Posted Apr 24, 2025 - 19:54 EDT

Investigating

We're currently experiencing slower-than-normal CSV report generation times. Additionally, a subset of users may encounter errors when attempting to generate these reports.

Our team is actively investigating and working to resolve the issue.
Posted Apr 24, 2025 - 19:30 EDT
This incident affected: Admin & Donor Tools.