Apple Pay is partially down

Incident Report for actblue

Resolved

Apple Pay payments is healthy again although we will continue to monitor the service for any further issues.
Posted Jul 17, 2025 - 20:26 EDT

Monitoring

Apple Pay payments is re-enabled and are monitoring the service.
Posted Jul 17, 2025 - 19:49 EDT

Investigating

Currently seeing errors with Apple Pay payments, Apple Pay is disabled while we investigate.
Posted Jul 17, 2025 - 16:12 EDT
This incident affected: Contribution Processing.